Figma prototype integration issues
Incident Report for Ballpark
Resolved
Figma have issued a fix for the problem affecting

- Goal tracking
- Clicks and Misclicks
- Prototype replay

All of these systems are now fully operational.
Posted Oct 27, 2023 - 22:02 UTC
Update
We have been notified of an incoming fix from Figma allowing for us to resume all functionality to our integration. Further information will be announced soon.
Posted Oct 27, 2023 - 19:23 UTC
Monitoring
We are currently monitoring this issue further and awaiting a fix from Figma.
Posted Oct 27, 2023 - 17:34 UTC
Update
We have now implemented and deployed a partial fix. This fix will allow prototypes for Goal and Free roam steps to load for participants.

Unfortunately there is still an ongoing issue with receiving events from Figma due to an API change. This means any statistics such as

- Measuring whether a goal was hit
- Clicks and Misclicks on a prototype
- Prototype Replays

Will not work correctly. We are working with Figma to resolve this remaining problem.

For the moment we recommend utilising Free Roam prototype steps on your tests and using follow up questions to confirm if a user has hit a goal or done a task correctly.

Apologies for the disruption.
Posted Oct 27, 2023 - 14:51 UTC
Update
We are currently testing a partial fix to allow prototypes to always load on a Goal based or Free roam task. This should be released soon.
Posted Oct 27, 2023 - 11:22 UTC
Identified
Due to a configuration change with our partner Figma, prototypes may not play back or record event information for Heatmaps and Replay.

The team are currently working on some fixes to ensure prototypes play for your tests. In addition we will work with Figma to restore event tracking capability to our systems for Prototype statistics, heatmaps and replay.
Posted Oct 27, 2023 - 10:18 UTC
Investigating
We are currently investigating issues with the Figma prototype integration
Posted Oct 27, 2023 - 10:01 UTC
This incident affected: Figma.