Issues signing in via Google

Incident Report for Ballpark

Resolved

This incident has been resolved
Posted Mar 04, 2025 - 18:48 UTC

Investigating

We are currently investigating reports of users unable to sign in to Ballpark using Google authentication
Posted Mar 04, 2025 - 18:06 UTC