Figma OAuth Connection Issues

Incident Report for Ballpark

Resolved

This incident has been resolved.
Posted Nov 19, 2025 - 21:44 UTC

Monitoring

A fix has been implemented to re-enable oAuth authentication to Figma and we are monitoring the performance.
Posted Nov 19, 2025 - 18:50 UTC

Identified

We've determine the cause of the issue and are now coordinating a fix to re-enable authed Figma imports.
Posted Nov 19, 2025 - 11:48 UTC

Investigating

We are currently investigating an issue affecting the connection between Ballpark and Figma for some users when attempting to import prototypes. Users may see errors when connecting their Figma account or importing files with restricted permissions.

Publicly shared prototypes may continue working as expected. We’ll provide further updates as we identify the cause and implement a fix.
Posted Nov 19, 2025 - 11:39 UTC
This incident affected: Ballpark Builder and Figma.