Recruitment: Issues submitting Enhanced & B2B orders

Incident Report for Ballpark

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:24 UTC

Investigating

We are currently investigating reports of users being unable to submit Enhanced and Enhanced B2B recruitment orders. This is likely due to our recruitment partner being impacted by to the ongoing AWS outage.
Posted Oct 20, 2025 - 09:50 UTC
This incident affected: Response system.